В WordPress существует автоматическое обновление темы, плагинов и самого ядра, но не всегда включение данного параметра способствует продуктивной работе сайта и магазина.

Представьте ситуацию когда вам пришлось напрямую внести какие-либо корректировки в плагин, например не нашли нужный хук или самостоятельно устранили ошибку, которая допустим проявляется только в работе вашего сайта, но автоматическое обновление WordPress может вызвать критическую ошибку в работе плагина и сайт становится не рабочим, к сожалению вы можете об этом даже не узнать.
В моей практике были подобные случаи, удовольствия от них совсем нет, да и финансово от таких обновлений я пострадал.

Отключение обновлений WordPress

Для отключения автоматического обновления WordPress рекомендую в файл wp-config.php прописать один из следующих параметров.

define( 'WP_AUTO_UPDATE_CORE', false ); //Полностью отключить автообновления
define( 'WP_AUTO_UPDATE_CORE', true ); //Включить автообновления
define( 'WP_AUTO_UPDATE_CORE', 'minor' ); //Включить только технические автообновления, например с версии 4.9.1 до 4.9.2 сайт будет обновляться, но с версии 4.9.1 до 5.0  обновляться не будет.

Если вам не нравится уведомление о новой версии WordPress, то пропишите следущий код в файл function.php. Думаю данный код обязателен, если к административной панели сайта имеют доступ другие пользователи.

//WooHelp.ru
//WordPress 4.9.1
function woohelp_remove_update(){
 woohelp_remove_update( 'index.php', 'update-core.php' );
}
add_action( 'admin_menu', 'woohelp_remove_update' );

Отключение обновление плагинов

Существуют несколько способов отключения запросов на обновление плагинов WordPress: в файлах самого плагина или в файле function.php. Я расскажу о первом способе, так как второй мне кажется более трудный.

Для отключения обновления перейдите в папку плагина и откройте главный файл в формате php (например плагин WooCommerce, в соответствующей папке главный файл woocommerce.ph).
Далее найдите в коде строку с версией плагина, в моей случае Version и измените номер версии.
Отключение обновления плагинов WordPress

Не забываем, что лучше отключать подобные обновление WordPress и плагинов, если вы корректировали файлы или у вас есть устаревшие плагины, так как при любом обновлении работоспособность вашего сайта может быть под угрозой.